Directory Traversal Affecting plexus-archiver package, versions <3.6.0-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
11.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-PLEXUSARCHIVER-1557425
  • published27 Jun 2018
  • disclosed25 Jul 2018

Introduced: 27 Jun 2018

CVE-2018-1002200  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:12 plexus-archiver to version 3.6.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream plexus-archiver package and not the plexus-archiver package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.