Improper Validation Affecting github.com/gravitational/teleport/lib/client Open this link in a new tab package, versions <4.0.16 >=4.1.0 <4.1.10 >=4.2.0 <4.2.7


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGRAVITATIONALTELEPORTLIBCLIENT-564514

  • published

    7 Apr 2020

  • disclosed

    1 Apr 2020

  • credit

    Unknown

Introduced: 1 Apr 2020

CWE-20 Open this link in a new tab

How to fix?

Upgrade github.com/gravitational/teleport/lib/client to version 4.0.16, 4.1.10, 4.2.7 or higher.

Overview

github.com/gravitational/teleport/lib/client is a privileged access management tool.

Affected versions of this package are vulnerable to Improper Validation. Host certificate validation was disabled for clusters where connections were terminated at the node, giving an attacker the ability to impersonate a Teleport node without detection when connecting through the Web UI.