Arbitrary Code Execution Affecting org.apache.geronimo.framework:geronimo-jmx-remoting Open this link in a new tab package, versions [3.0.0-beta-1,3.0.1)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEGERONIMOFRAMEWORK-30620

  • published

    8 Jun 2014

  • disclosed

    11 Jul 2013

  • credit

    Pierre Ernst of IBM Canada Ltd

How to fix?

Upgrade org.apache.geronimo.framework:geronimo-jmx-remoting to version 3.0.1 or higher.

Overview

org.apache.geronimo.framework:geronimo-jmx-remoting is an open source application server developed by the Apache Software Foundation and distributed under the Apache license.

Affected versions of this package are vulnerable to Arbitrary Code Execution. It does not properly implement the RMI classloader, which allows remote attackers to execute arbitrary code by using the JMX connector to send a crafted serialized object.