Incorrect Authorization Affecting org.apache.ignite:ignite-core Open this link in a new tab package, versions [,2.8.1)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEIGNITE-571662

  • published

    7 Jun 2020

  • disclosed

    7 Jun 2020

  • credit

    Unknown

How to fix?

Upgrade org.apache.ignite:ignite-core to version 2.8.1 or higher.

Overview

org.apache.ignite:ignite-core is a memory-centric distributed database, caching, and processing platform for transactional, analytical, and streaming workloads delivering in-memory speeds at petabyte scale.

Affected versions of this package are vulnerable to Incorrect Authorization. It uses H2 database to build SQL distributed execution engine. H2 provides SQL functions which could be used by attacker to access to a filesystem.

References