Information Exposure Affecting org.apache.tomcat:tomcat-coyote Open this link in a new tab package, versions [7.0.0,7.0.22)

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    10 Jun 2015

  • disclosed

    19 Jan 2012

  • credit


How to fix?

Upgrade org.apache.tomcat:tomcat-coyote to version 7.0.22 or higher.


org.apache.tomcat:tomcat-coyote is a Tomcat Connectors and HTTP parser.

Affected versions of this package are vulnerable to Information Exposure. Apache Tomcat 6.0.30 through 6.0.33 and 7.x before 7.0.22 does not properly perform certain caching and recycling operations involving request objects, which allows remote attackers to obtain unintended read access to IP address and HTTP header information in opportunistic circumstances by reading TCP data.