Information Exposure Affecting org.apache.tomcat:tomcat-coyote Open this link in a new tab package, versions [7.0.0,7.0.47) [8.0.0-RC1,8.0.0-RC3)
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
3 Mar 2015
26 Feb 2014
How to fix?
org.apache.tomcat:tomcat-coyote to version 7.0.47, 8.0.0-RC3 or higher.
org.apache.tomcat:tomcat-coyote is a Tomcat Connectors and HTTP parser.
Affected versions of this package are vulnerable to Information Exposure. Apache Tomcat before 6.0.39, 7.x before 7.0.47, and 8.x before 8.0.0-RC3, when an HTTP connector or AJP connector is used, does not properly handle certain inconsistent HTTP request headers, which allows remote attackers to trigger incorrect identification of a request's length and conduct request-smuggling attacks via (1) multiple Content-Length headers or (2) a Content-Length header and a "Transfer-Encoding: chunked" header.
NOTE: this vulnerability exists because of an incomplete fix for CVE-2005-2090.