HTTP Request Smuggling Affecting org.apache.tomcat:tomcat-coyote package, versions [7.0.0,7.0.55) [8,8.0.9)


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHETOMCAT-30935
  • published 16 Feb 2015
  • disclosed 16 Feb 2015
  • credit Unknown

How to fix?

Upgrade org.apache.tomcat:tomcat-coyote to version 7.0.55, 8.0.9 or higher.

Overview

org.apache.tomcat:tomcat-coyote is a Tomcat Connectors and HTTP parser.

Affected versions of this package are vulnerable to HTTP Request Smuggling. It does not properly handle attempts to continue reading data after an error has occurred, which allows remote attackers to conduct HTTP request smuggling attacks or cause a denial of service (resource consumption) by streaming data with malformed chunked transfer coding.