Information Exposure Affecting puma package, versions <4.3.11 >=5.0.0, <5.6.2

  • Attack Complexity


  • User Interaction


  • Scope


  • Confidentiality


  • Integrity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    13 Feb 2022

  • disclosed

    13 Feb 2022

  • credit

    Jean Boussier

How to fix?

Upgrade puma to version 4.3.11, 5.6.2 or higher.


puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications. Puma is intended for use in both development and production environments. It's great for highly concurrent Ruby implementations such as Rubinius and JRuby as well as as providing process worker support to support CRuby well.

Affected versions of this package are vulnerable to Information Exposure via the close function which is not always called on the response body in puma. As a result, Rails, which depends on the response body being closed in order for its CurrentAttributes implementation to work correctly, can leak information. This is related to CVE-2022-23633. Upgrading to a patched Rails or Puma version fixes the vulnerability.