OS Command Injection Affecting openssl-1_1 package, versions <1.1.1d-150200.11.48.1


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 10.65% (96th percentile)
Expand this section
NVD
9.8 critical
Expand this section
SUSE
6.7 medium
Expand this section
Red Hat
6.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-OPENSSL11-2941083
  • published 5 Jul 2022
  • disclosed 4 Jul 2022

How to fix?

Upgrade SLES:15.3 openssl-1_1 to version 1.1.1d-150200.11.48.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-1_1 package and not the openssl-1_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

The c_rehash script does not properly sanitise shell metacharacters to prevent command injection. This script is distributed by some operating systems in a manner where it is automatically executed. On such operating systems, an attacker could execute arbitrary commands with the privileges of the script. Use of the c_rehash script is considered obsolete and should be replaced by the OpenSSL rehash command line tool. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2). Fixed in OpenSSL 1.1.1o (Affected 1.1.1-1.1.1n). Fixed in OpenSSL 1.0.2ze (Affected 1.0.2-1.0.2zd).

References