openssl-1_1 vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the openssl-1_1 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • L
CVE-2024-0727

<1.1.1d-150200.11.85.1
  • H
Loop with Unreachable Exit Condition ('Infinite Loop')

<1.1.1d-11.43.1
  • M
Improper Check for Unusual or Exceptional Conditions

<1.1.1d-150200.11.82.1
  • M
Excessive Iteration

<1.1.1d-150200.11.75.1
  • M
Inefficient Regular Expression Complexity

<1.1.1d-150200.11.72.1
  • M
Information Exposure

<1.1.1d-150200.11.72.1
  • M
Allocation of Resources Without Limits or Throttling

<1.1.1d-150200.11.65.1
  • M
Improper Certificate Validation

<1.1.1d-150200.11.62.1
  • M
Improper Certificate Validation

<1.1.1d-150200.11.62.1
  • M
Improper Certificate Validation

<1.1.1d-150200.11.62.1
  • H
Access of Resource Using Incompatible Type ('Type Confusion')

<1.1.1d-150200.11.57.1
  • M
Use After Free

<1.1.1d-150200.11.57.1
  • M
Double Free

<1.1.1d-150200.11.57.1
  • M
Information Exposure

<1.1.1d-150200.11.57.1
  • H
NULL Pointer Dereference

<1.1.1d-11.20.1
  • H
Use of a Broken or Risky Cryptographic Algorithm

<1.1.1d-150200.11.51.1
  • M
OS Command Injection

<1.1.1d-150200.11.48.1
  • M
OS Command Injection

<1.1.1d-150200.11.48.1
  • C
Buffer Overflow

<1.1.1d-11.27.1
  • M
Out-of-bounds Read

<1.1.1d-11.27.1
  • M
Out-of-bounds Read

<1.1.1d-11.30.1