Improper Certificate Validation Affecting openssl-1_1 package, versions <1.1.1d-150200.11.62.1


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.26% (66th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-OPENSSL11-5416218
  • published 7 Apr 2023
  • disclosed 6 Apr 2023

How to fix?

Upgrade SLES:15.3 openssl-1_1 to version 1.1.1d-150200.11.62.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-1_1 package and not the openssl-1_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

A security vulnerability has been identified in all supported versions

of OpenSSL related to the verification of X.509 certificate chains that include policy constraints. Attackers may be able to exploit this vulnerability by creating a malicious certificate chain that triggers exponential use of computational resources, leading to a denial-of-service (DoS) attack on affected systems.

Policy processing is disabled by default but can be enabled by passing the -policy&#39; argument to the command line utilities or by calling the X509_VERIFY_PARAM_set1_policies()' function.