Improper Certificate Validation Affecting openssl-1_1 package, versions <1.1.1d-150200.11.62.1


0.0
medium
0
10

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.13% (48th percentile)
Expand this section
NVD
5.3 medium
Expand this section
SUSE
5.9 medium
Expand this section
Red Hat
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES153-OPENSSL11-5416254
  • published 7 Apr 2023
  • disclosed 6 Apr 2023

How to fix?

Upgrade SLES:15.3 openssl-1_1 to version 1.1.1d-150200.11.62.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openssl-1_1 package and not the openssl-1_1 package as distributed by SLES. See How to fix? for SLES:15.3 relevant fixed versions and status.

Applications that use a non-default option when verifying certificates may be vulnerable to an attack from a malicious CA to circumvent certain checks.

Invalid certificate policies in leaf certificates are silently ignored by OpenSSL and other certificate policy checks are skipped for that certificate. A malicious CA could use this to deliberately assert invalid certificate policies in order to circumvent policy checking on the certificate altogether.

Policy processing is disabled by default but can be enabled by passing the -policy&#39; argument to the command line utilities or by calling the X509_VERIFY_PARAM_set1_policies()' function.