Heap-based Buffer Overflow Affecting radareorg/radare2 Open this link in a new tab package, versions [,5.6.0)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-UNMANAGED-RADAREORGRADARE2-2847866

  • published

    25 May 2022

  • disclosed

    25 May 2022

  • credit

    Census Labs

How to fix?

Upgrade radareorg/radare2 to version 5.6.0 or higher.

Overview

Affected versions of this package are vulnerable to Heap-based Buffer Overflow in the obj_build_refs function, in the /radare2/libr/core/anal_objc.c file.